1. Главная страница » Компьютеры

List index out of bounds орион про

Автор: | 16.12.2019

Ряд пользователей ПК при отладке какой-либо из своих программ (или при запуске какого-либо софта) могут столкнуться с ошибкой «List Index out of bounds(-1,0)». Обычно она связана с неточностями, допущенными разработчиками при написании кода программы. Но также бывают и ситуации, когда появление ошибки связано с некорректной работой на ПК ряда программных продуктов. В этом материале я расскажу, что за ошибка «List Index out of bounds(-1,0)», каковы причины её возникновения, и как её исправить на вашем ПК.

Возникшая ошибка «List Index out of bounds» при установке «K-Lite Codec Pack»

List index out of bounds (-1,0) — что за ошибка

В переводе текст данной ошибки звучит как «списочный номер вне допустимых границ», и обычно означает ситуацию, когда в коде программы одно из её значений установлено некорректно. Например, разработчик программы где-либо допустил ошибку при работе с циклом, или какая-либо часть программы работает с переменной, которая удалена или не существует.

Также причиной данной проблемы может быть неправильная установка проблемной программы, а также ситуация, при которой какой-либо софт на вашем ПК конфликтует с данной программой, вследствие чего возникает рассматриваемая мной дисфункция.

Ошибка «List Index out of bounds(-1,0)» при отладке программы

Как исправить ошибку «List index out of bounds(-1,0)»

Если вы разработчик программного кода, и получили данную ошибку во время трассировки, рекомендую ещё раз проверить текст вашей программы на наличие ошибок. К примеру, в теле программы вы пытаетесь работать с теми строками, которых, de facto, не существует.

Читайте также:  Gigabyte ga ep35c ds3r характеристики

Если ошибка найдена не была, тогда стоит обратиться с вашей программой на форумы программистов, работающих в одной с вами программной среде (использующих один API). Обычно там вас попросят предоставить кусок программы, в работе которой возникает ошибка «List index out of bounds», и после ознакомления с его текстом дадут конкретный совет, где находится неверно указанное вами программное значение.

Обратитесь за помощью на форум программистов

Другие способы исправить ошибку

Если же данная ошибка возникла при работе установленной на компьютер внешней программы, рекомендую сделать следующее:

  • Переустановите проблемную программу . Рекомендую деинсталлировать её стандартным путём, перезагрузить ваш компьютер, а затем заново установить данную программу. Особенно это касается сбоев с возникновением ошибки «List Index out of bounds(-1,0)» в работе «Skype»;
  • Запускайте данную программу от имени администратора . Наведите курсор на её ярлык на рабочем столе, кликните правой клавишей мыши, и в появившемся меню выберите «Запуск от имени администратора»;

Используйте запуск программы от имени администратора

  • Запустите вашу программу в режиме совместимости с более ранней версией ОС . Наведите курсор на иконку программы на рабочем столе, нажмите правую клавишу мыши, выберите «Свойства». В открывшемся окне перейдите на вкладку «Совместимость», и установите галочку рядом с опцией «Запустить программу в режиме совместимости с», выбрав более раннюю версию ОС. Сохраните изменения, нажав на «Ок», и попытайтесь запустить проблемную программу;
  • Обновите Java на вашем компьютере (скачайте самую свежую версию «Java» с ресурса Java.com);
  • Обновите Java на вашем ПК

  • Попробуйте удалить файл настроек проблемной программы (он может иметь расширение .ini). Программа должна вновь создать данный файл, и ошибка «List Index out of bounds(-1,0)» может быть устранена;
  • Узнайте, не было ли патчей для проблемной программы, исправляющих указанный баг (при необходимости, найдите и установите такой патч на ваш ПК);
  • Проверьте ваш компьютер на наличие вирусных программ . Помогут Dr.Web CureIt!, Malwarebytes Anti-Malware, AdwCleaner и другие аналогичные продукты.
  • Используйте «AdwCleaner» для борьбы со зловредами на вашем ПК

    Заключение

    В данном материале я рассмотрел значение ошибки List index out of bounds, и как инструкцию по исправлению данной ошибки. В большинстве случаев причиной возникновения проблемы является некорректный программный код, созданный разработчиком на каком-либо из языков программирования. Рекомендуется ещё раз внимательно проверить значения, использованные в теле программы, а при необходимости обратиться на форум программистов, предоставив им для анализа проблемный кусок кода. Обычно решение быстро находиться, позволяя избавиться от ошибки List Index out of bounds(-1,0) на вашем ПК.

    На форме есть компонент sListBox1 (разновидность ListBox1 в Alpha Controls).
    Туда добавляются элементы
    sListBox1.Items.Add(‘. ‘);

    В коде мне нужно перебрать все элементы этого sListBox1 . Работа идет в потоке.

    При добавлении более одного файла, возникает ошибка
    Ошибка listerror list index out of bounds (1).

    Как исправить ошибку listerror list index out of bounds?

    • Вопрос задан 02 апр.
    • 336 просмотров

    Границы счётчика FOR вычисляется один раз перед циклом. Если в основном потоке меняется form1.sListBox1 , то может не оказаться нужного Items[i] . Или проверяйте его наличие. Или используйте цикл WHILE , в котором сравнение счётчика с условием будет проверяться каждый раз.
    Замечание: оптимизатор может изменить направление FOR .

    Совет: не связывайте модули.
    То есть у TMyThread должен быть свой TStrings , в который нужно передать form1.sListBox1.Items .

    Не очень понял.
    Я добавляю в sListBox1 элементы. И запускаю цикл.
    Ничего в потоке в sListBox1 не добавляю. Как там всё было, так и есть.

    Я добавляю в sListBox1, с помощью Opendialog путь к файлу.
    И в цикле открываю файлы.
    Простая, типовая задача.

    Здравствуйте, уважаемые коллеги.

    Возможная причина проблемы — некорректные шифры изданий, находящихся в данный момент на бронеполке (шифр издания на бронеполке, указанный в записи заказа, не соответствует шифру издания в БД ЭК).
    Можно войти в АРМ под тем логином, для которого вход выполняется нормально, затем установить в настройках место выдачи и место хранения в *, интервал автоматического обновления 0; проверить шифры изданий на бронеполке; если есть ошибки несоответствия шифров, то исправить их.

    (При большом количестве заказов на бронеполке для быстрой проверки можно предварительно отредактировать формат DATAIRQSTRQST_HTML.pft, добавить строку:
    ‘
    Проверка шифра: ‘,&uf(‘D’,v1,",!I="v903"!,v903"),)

    Спасибо. Дополнительный вопрос: правильно ли у Вас установлены изменения версии 2010.1 (по сравнению с 2009.1) и обновления? Например, в обновлении IRBIS64_10D1 есть изменения в RDR.fst, RQST.fst.

    Александр Иосифович 20.10.2010 г. отмечал, что сообщение "List index out of bounds" при старте АРМ Книговыдача появляется, так как в БД RQST есть ошибочные даты. Поэтому хотел бы задать вопрос, в чём именно может заключаться ошибка в датах, как такие ошибочные даты найти?

    Александр Иосифович, здравствуйте.

    К сожалению, у нас тоже появилась ошибка "List index out of bounds (0)" при запуске АРМ Книговыдача 2010.1.
    Ошибка появляется не при каждом запуске.
    Скажите, пожалуйста, ошибка может возникать из-за ошибочных дат в БД RQST (если да, то как их найти)?

    * АРМ Книговыдача 2010.1 от 27.01.2011 г.( [irbis.gpntb.ru] ).

    Редактировано 2 раз. Последний раз 02.03.2011 10:28 пользователем PRM.

    PRM написал(а):
    ——————————————————-
    > Александр Иосифович, здравствуйте.
    >
    > К сожалению, у нас тоже появилась ошибка "List
    > index out of bounds (0)" при запуске АРМ
    > Книговыдача 2010.1.
    > Ошибка появляется не при каждом запуске.
    Мне нужен воспроизводимый пример.

    > Скажите, пожалуйста, ошибка может возникать из-за
    > ошибочных дат в БД RQST (если да, то как их
    > найти)?
    Если бы были ошибочные даты, появлялось бы соответствующее сообщение.

    > Если бы были ошибочные даты, появлялось бы
    > соответствующее сообщение.

    К сожалению, не понял. Появилось бы сообщение при запуске АРМ Книговыдача?

    Александр Иосифович, воспроизводимый пример подготовить на данный момент не удалось.

    Запустили режим отладки сервера ИРБИС64.
    Результаты показывают:
    — в АРМ Книговыдача выдаётся сообщение "List index out of bounds (0)".
    В этот момент:
    — в списке зарегистрированных пользователей для данного клиента номер последней команды — 1317. Текущая команда — IRBIS_POSTING.

    Файлы запроса и ответа 118199_1317, !118199_1317 — во вложении.
    Файл ответа 118199_1317 содержит "-401" — ERR_FILEINVERT — ошибка при открытии trm файлов.

    Может ли сообщение "List index out of bounds (0)" быть связанным с "ERR_FILEINVERT" ?

    Редактировано 1 раз. Последний раз 22.03.2011 11:51 пользователем PRM.

    Александр Иосифович, здравствуйте.

    Извините, пожалуйста, что вновь задаю вопрос.

    Может ли сообщение "List index out of bounds (0)" при входе в АРМ или при нажатии Shift-F5 в АРМ Книговыдача быть связанным с ответом сервера "-401" ?

    Думаю, что проблема актуальная: при входе в АРМ, если появляется "List index out of bounds (0)", то на экране остаётся заставка с ИРБИСом. Иногда вход выполняется нормально (заставка с ИРБИСом пропадает), например, только с третьей или четвёртой попытки.

    Илья Иванович в теме "Расшифровки кодов ошибок сервера ИРБИС 64" ( [irbis.gpntb.ru] ) приводит другую расшифровку ошибки -401: вместо "ERR_FILEINVERT — ошибка при открытии trm файлов" — "-401 — Ошибка файла индекса".
    Но в нашем случае диагностика файла словаря БД CAT (электронного каталога) через АРМ Администратор никаких ошибок не показывает.

    АРМ Книговыдача 2010.1 D3.

    > Не понял. Так что сначала выдается: List index или
    > -401?

    Александр Иосифович, List index выдавался в АРМ, а "-401" в файле ответа сервера для последней выполненной команды (данного АРМ).

    (22 марта был выполнен следующий тест:
    в АРМ Книговыдача:
    — появилось сообщение "List index out of bounds (0)";
    — выполнено нажатие на OK в окне сообщения;
    — установлен интервал автоматического обновления "0";
    — несколько раз с интервалами до 5 секунд выполнено нажатие на Shift-F5;
    — после нажатия на Shift-F5 появилось сообщение "List index out of bounds (0)";

    на сервере был включён режим отладки;

    в АРМ Книговыдача:
    — выполнено нажатие на OK в окне сообщения;
    — несколько раз с интервалами до 5 секунд выполнено нажатие на Shift-F5;
    — после нажатия на Shift-F5 появилось сообщение "List index out of bounds (0)";

    в АРМ Администратор проверен номер (N) последней команды для АРМ Книговыдача;

    в директории workdir проверены файлы запроса клиента и ответа сервера для команды N (файлы приведены в сообщении от 22 марта). В файле ответа обнаружена ошибка "-401".)

    > Удалите весь раздел [DESKTOP] cirbisb.ini и повторите вход
    > в АРМ.

    > > Удалите весь раздел [DESKTOP] cirbisb.ini и повторите
    > вход
    > > в АРМ.
    >
    > Хорошо. Проверим.

    Александр Иосифович, сейчас при входе в АРМ появилось сообщение "List index. ".
    Удалили раздел [DESKTOP], повторили вход в АРМ.
    Сообщение "List index. " появилось снова (скриншот).

    Редактировано 1 раз. Последний раз 30.03.2011 12:42 пользователем PRM.

    >
    > Александр Иосифович, сейчас при входе в АРМ
    > появилось сообщение "List index. ".
    Что значит "сейчас"?
    > Удалили раздел , повторили вход в АРМ.
    > Сообщение "List index. " появилось снова
    > (скриншот).
    Надеюсь, ВЫ удаляли раздел [DESKTOP] после того, как закрыли АРМ?
    С БД RQST все в порядке?
    Пришлите мне cirbisb.ini при котором возникает List index.

    Alio написал(а):
    ——————————————————-
    > PRM написал(а):
    > —————————————————
    > ——
    >
    > >
    > > Александр Иосифович, сейчас при входе в АРМ
    > > появилось сообщение "List index. ".
    > Что значит "сейчас"?
    > > Удалили раздел , повторили вход в АРМ.
    > > Сообщение "List index. " появилось снова
    > > (скриншот).
    > Надеюсь, ВЫ удаляли раздел после того, как
    > закрыли АРМ?

    "Сейчас" означает, что ошибка появляется не при каждом запуске.
    Раздел [Desktop] удалял после того, как закрыл АРМ.

    Проблема: ошибка "List index. " — "плавающая". Ошибка появилась при запуске с настройками cirbisb.ini (и заполненной секцией [Desktop]). Если повторить запуск на этом же cirbisb.ini (содержимое совпадает полностью), то ошибка не появляется.

    > С БД RQST все в порядке?

    1) Диагностика файла документов, диагностика словаря показывают, что ошибок не обнаружено.
    2) В БД RQST было 11 записей, в которых было заполнено только поле 24 (значение поля — пробел). Удалил эти записи логически.
    Сейчас рабочий день уже закончился, удалю выполненные заказы и отказы, экспортирую записи, опустошу RQST, импортирую, создам словарь заново полностью.

    > Пришлите мне cirbisb.ini при котором возникает
    > List index.

    На всякий случай, прикрепляю cirbisb.ini, на котором ошибка "List index. " была как минимум один раз зафиксирована.

    Редактировано 1 раз. Последний раз 30.03.2011 15:20 пользователем PRM.

    Александр Иосифович, здравствуйте.

    Скажите, пожалуйста, можете ли Вы внести следующую доработку?
    —
    Если при запуске АРМ Книговыдача появляется сообщение "List index out of bounds (0)" на фоне окна с информацией о системе ИРБИС64, то после нажатия OK в окне "List index out of bounds (0)" закрывать окно с информацией о системе.
    —

    Александр Иосифович, а ответ "-401" сервера ИРБИС64 на запрос АРМ Книговыдача может быть причиной "List index out of bounds (0)" (как в файлах отладки в сообщении от 22, March, 2011 14:30)?

    Редактировано 1 раз. Последний раз 13.04.2011 15:21 пользователем PRM.

    Alio написал(а):
    ——————————————————-
    > Если эта ошибка воспроизводима, передайте мне
    > соответствующие данные.

    Александр Иосифович, скопировал нашу конфигурацию ИРБИС на рабочий компьютер. При запуске нескольких АРМ Книговыдача и последовательном нажатии Shift-F5 в каждом из них ошибка появляется, но, к сожалению, с небольшой вероятностью. Попробую уменьшить объём данных, так чтобы ошибка воспроизводилась.

    Alio написал(а):
    ——————————————————-
    > Если эта ошибка воспроизводима, передайте мне
    > соответствующие данные.

    Александр Иосифович, здравствуйте.

    Готовы передать Вам соответствующие данные. (Идёт упаковка в rar, объём неупакованных данных — 3,75 ГБ.)

    Тест включает БД ЭК: CAT, CATD; БД RDR, БД RQST.
    Настройки сервера используются стандартные, за исключением:
    MAX_PROCESS_COUNT=20, CLIENT_TIME_LIVE=30, PROCESS_TIME_LIVE=15, ENCRYPT_PASSWORDS=0

    Серверная и клиентская часть соответствует обновлению D5 2010.1

    Описание теста: на локальной машине запущен irbis_server.exe, затем запущены под логином 1 и паролем 1 несколько АРМ Книговыдача 2011.1 (маски фильтров — *, интервал автоматического обновления — 10 секунд).
    Пользователь не выполняет операции с АРМ.
    Через некоторое время на одном из клиентов наблюдается сообщение "List index out of bounds (0)". При просмотре в списке зарегистрированных клиентов для данного клиента последняя команда — IRBIS_POSTING. Файлы отладки показывают, что в ответ на последнюю команду данного клиента сервер дал ответ "-401".

    Александр Иосифович, первое впечатление: сегодня количество монопольных блокировок баз данных электронных каталогов и блокировок отдельных записей выше обычного.

    При автоматическом обновлении теперь на несколько секунд появляется окно "Ожидание ответа от сервера", и происходит переключение с активного приложения на АРМ Книговыдача. В связи с таким переключением, работать в других приложениях неудобно.

    PRM написал(а):
    ——————————————————-
    > Александр Иосифович, первое впечатление: сегодня
    > количество монопольных блокировок баз данных
    > электронных каталогов и блокировок отдельных
    > записей выше обычного.
    При чем тут блокировки? С таким же успехом Вы могли мне сообщить, что после установки нового АРМа Книговыдача упало напряжение в электросети.

    > При автоматическом обновлении теперь на несколько
    > секунд появляется окно "Ожидание ответа от
    > сервера", и происходит переключение с активного
    > приложения на АРМ Книговыдача. В связи с таким
    > переключением, работать в других приложениях
    > неудобно.
    Это не связано с теми изменениями, которые были сделаны в АРМе.

    Alio написал(а):
    ——————————————————-
    > PRM написал(а):
    > —————————————————
    > ——
    > > Александр Иосифович, первое впечатление:
    > сегодня
    > > количество монопольных блокировок баз данных
    > > электронных каталогов и блокировок отдельных
    > > записей выше обычного.
    > При чем тут блокировки? С таким же успехом Вы
    > могли мне сообщить, что после установки нового
    > АРМа Книговыдача упало напряжение в
    > электросети.
    >

    Не знаю.
    Возможно, в связи с увеличением нагрузки на сервер? (В новом модуле для заказов на бронеполке при автоматическом обновлении выполняется не mpl,&UNIFOR(‘+0’), а &unifor(‘+0’),&unifor(‘D’,v1,’,|I=’,v903,’|,@freekz0′),/&unifor(‘D’,v1,’,|I=’,v903,"|,’1000#’,mfn"d1)).

    > > При автоматическом обновлении теперь на
    > несколько
    > > секунд появляется окно "Ожидание ответа от
    > > сервера", и происходит переключение с активного
    > > приложения на АРМ Книговыдача. В связи с таким
    > > переключением, работать в других приложениях
    > > неудобно.
    > Это не связано с теми изменениями, которые были
    > сделаны в АРМе.

    Александр Иосифович, тогда скажите, пожалуйста, можно ли ввести параметр, который управлял бы принципом запуска автоматического обновления?

    > Это новшество потребовало изменить принцип
    > автоматического запуска обновления очереди заказов
    > (по НАСТРОЙКЕ): в прежних (2010.1 и ниже) версиях
    > автоматическое обновление очереди происходило
    > только в случае, когда приложение активно, в
    > 2011.1 обновление очереди происходит во всех
    > случаях (т.е и тогда, когда оно свернуто или не в
    > фокусе ввода). В связи с этим вопрос к
    > пользователям: стоит ли вводить параметр, который
    > бы управлял этим принципом запуска. Кроме этого —
    > нужен ли параметр разрешающий/отменяющий подачу
    > звукового сигнала.

    Добавить комментарий

    Ваш адрес email не будет опубликован. Обязательные поля помечены *